Difference between disk 0 and disk 1

Why is my mechanism drive established as Disk 1 and also not Disk 0? What determines these values? Is it to what SATA port the drive is attached to?

If I pull out my second, my primary transforms to Disk 0.

You watching: Difference between disk 0 and disk 1

I know this does not really issue however is tright here a way in Windows to readjust this?

*
*
vr-tab-quebec.com Treasury

Phantom Helix 53

um......
*
532,543 postsLocation: Minnesota, USA

OP FusionGuy 0

vr-tab-quebec.comian
*
0308 posts

soldier1st 40

Software Tester/Tech/Linux Lover 405,335 postsLocation: Guess WhereOS: Windows 7,Android,Linux MintPhone: HTC Incredible S

it sounds choose you have actually your major drive in sata plug 1 and also your second in sata slot 0 so to deal with that put your primary sata drive in the sata 0 connector on the mobo and also execute the same for your various other sata drive yet area it in sata slot 1 but if you have actually an ide tough drive and a sata drive then the ide will come initially then the sata.


What happens when you put "Primary" to Sata 1 and also second to Sata 2 (or any type of various other Sata port) ?

Obviously Windows boot partition is on Primary?


Bryan R. 1,152

vr-tab-quebec.comian Senior 1,1525,483 postsLocation: Palm Beach, FLOS: Windows 10Phone: Microsoft Lumia 950

Those labels are even more of a hardware level identification definition that is just how your motherboard is reporting the drives. Logically, you"d think that the motherboard would report them in the exact same order as the ports, but it"s all up to the motherboard and is normally strictly behind-the-scenes as any type of application you have actually would certainly not utilise the hardware Disk X identifier, but quite an extra software program level C:, D:, and so on.

You deserve to try rearvarying the drives to view if you have the right to discover what SATA ports will certainly yield the wanted Disk X.

See more: Broadcom Netxtreme 57Xx Gigabit Controller Driver, Fix: Broadcom Netxtreme 57Xx Gigabit Controller

Edited August 4, 2009 by lord_xenos

Bryan R. 1,152

vr-tab-quebec.comian Senior 1,1525,483 postsLocation: Palm Beach, FLOS: Windows 10Phone: Microsoft Lumia 950

It"s all strictly labeling anymethod...and also yes, some motherboards and also server backplanes have actually their SATA ports labeled with SATA0 founding...


soldier1st 40

Software Tester/Tech/Linux Lover 405,335 postsLocation: Guess WhereOS: Windows 7,Android,Linux MintPhone: HTC Incredible S

my mobo has actually 4 sata ports and the first one is port 0 then 1 then 2 then 3 kimsland also yet the mobo is from 2003 so that might be why.


I think my m/b about that age and also it states Sata1

Oh well obviously it have the right to be either

The disk administration appears to be the best answer here


That"s dead on, other than I have them associated to SATA 4 and also SATA 5 bereason these 2 ports are on the side of the mobo and make for better cable monitoring.

See more: What Is Windows 8.1/10 Whql Support, Msi Gaming M3 Windows Whql Bios Option


I swapped the drives and also it looked good on the first boot. My main was Disk 0. I then shutdown and restarted the PC and also it went back to the various other means approximately. So it need to be somepoint within Windows or throughout setup of Windows that causes this. I don"t really desire to reinstall whatever just to view. :cry:


soldier1st 40

Software Tester/Tech/Linux Lover 405,335 postsLocation: Guess WhereOS: Windows 7,Android,Linux MintPhone: HTC Incredible S

did you inspect the bios for those alternatives prefer to disable half the sata ports and also keep 1 and also 2 active?


Has anyone else been suffering this? It seems prefer it"s intermittent. On some boots my major is provided as Disk 0 and periodically Disk 1.... stupid windows :laugh:


soldier1st 40

Software Tester/Tech/Linux Lover 405,335 postsLocation: Guess WhereOS: Windows 7,Android,Linux MintPhone: HTC Incredible S

so if it"s intermittent then it sounds prefer your experiencing from a pest, perhaps this website may have a resolve for you http://itsvista.com/topic/hotfix/ but i have 2 sata drives yet i am not suffering this worry, do you have sp2 installed and also all updates?also have you tried autopatcher?


Yes I have SP2 and also totally updated. I"ll have a look at that website and also check out if tbelow is anything that resembles my concerns.


It seems like it"s intermittent. On some boots my primary is provided as Disk 0 and sometimes Disk 1.... stupid windows :laugh: